Cyberpunk 2077 pomimo tego, że jest produkcją dobrą, to cierpi na kilka mniejszych lub większych problemów, ale o tym wie chyba każdy, kto w niego grał.

Jednak jak niedawno poinformowano za pośrednictwem serwisu Reddit, najnowsze dzieło studia CD Projekt RED posiada również poważną lukę, która ma niesamowicie duże znaczenie w kontekście bezpieczeństwa naszych komputerów.




O całej sprawie poinformował PixelRick, modder należący do zespołu Red Tools. Użytkownik udostępnił nowinkę zarówno osobom w serwisie Reddit jak i deweloperom ze studia CD Projekt RED. Twórcy wiedzą już od tygodnia o problemie, jednak z jakiegoś powodu nie został on załatany w najnowszej aktualizacji 1.11.

Co to w praktyce oznacza? A mianowicie chodzi o to, że teoretycznie po pobraniu z internetu i zainstalowaniu modyfikacji, lub zapisów gry do Cyberpunka 2077 zainfekowanych złośliwym oprogramowaniem istnieje ryzyko, że haker może wykorzystać lukę i przejąć cały nasz komputer.

O ile pliki z popularnych serwisów pokroju nexusmods.com powinny być w miarę bezpieczne, tak nie ma pewności jak to będzie wyglądać z modyfikacjami z nowych lub mniej popularnych stron. Co ważne, problem w mniejszym zakresie dotyczy również wydania gry na PlayStation 4.


W wątku na Reddicie czytamy:

"Poprzez użycie modyfikacji lub spreparowanego zapisu gry, złośliwy kod może być wykorzystany w celu przejęcia kontroli nad komputerem przez twórcę zapisu / modyfikacji. CDPR został poinformowany o tej poważnej luce w zabezpieczeniach prawie tydzień temu. Wydali poprawkę 1.11, ale nie zadali sobie trudu, aby rozwiązać ten problem. Musimy podziękować PixelRick (Red Tools Team), którego odkrycie zwróciło uwagę społeczności moderów.

Edycja: Początkowo miałem wrażenie, że ta luka dotyczy tylko platformy PC, ale sam PixelRickyRick potwierdził, że PS4 również jest w pewnym stopniu podatne na tę lukę".


Więc jak się zabezpieczyć przed przejęciem komputera, a jednocześnie nie pozbawiać się frajdy z instalacji nowych modów? Jak się okazuje, problem naprawia najnowsza wersja niezwykle przydatnego moda CyberEngineTweaks, znajdującego się w serwisie GitHub, którego autor bardzo szybko zareagował na odkryte zagrożenie.

Niezwykle łatwo go zainstalować, wystarczy przerzucić pliki z archiwum CET do głównego folderu Cyberpunk 2077.

Jeżeli w obecnej sytuacji nie czujecie się komfortowo z instalacją modyfikacji, to polecamy wstrzymać się z jakimikolwiek nowymi modami, dopóki CD Projekt RED nie wypuści oficjalnej łatki.